It is currently Fri Jul 20, 2018 10:27 pm Advanced search

Submission stuck at 'Ready to be compiled'

Code won't compile? Found a bug? Post here!

Submission stuck at 'Ready to be compiled'

Postby gautham » Tue Nov 23, 2010 6:17 am

Hi

My first three submissions (in lisp) failed with the error message 'error while compiling submission', although the error messages show execution errors due to differences b/w the tools in the starter pack and the actual simulator (empty lines in the input). My fourth submission seems to be stuck with the status 'ready to be compiled' for quite some time (since 'Nov 22nd 23:17:48', not sure which timezone). Is there anyway of finding out what happened?

Regards
Gautham
gautham
Cadet
 
Posts: 4
Joined: Tue Nov 23, 2010 6:07 am
Location: Edinburgh, Scotland

Re: Submission stuck at 'Ready to be compiled'

Postby Janzert » Tue Nov 23, 2010 6:46 am

Gauthum in trying to work out what went wrong with the compilation process I accidently caused your entry to be rejected with it not finding the language. Please just resubmit.

Sorry for the trouble,
Janzert
Janzert
Contest Organizer
 
Posts: 271
Joined: Sun Feb 07, 2010 1:59 am

Re: Submission stuck at 'Ready to be compiled'

Postby gautham » Tue Nov 23, 2010 7:27 am

No problem.

Thanks and regards
Gautham
gautham
Cadet
 
Posts: 4
Joined: Tue Nov 23, 2010 6:07 am
Location: Edinburgh, Scotland

Re: Submission stuck at 'Ready to be compiled'

Postby gautham » Tue Nov 23, 2010 8:13 am

And it's back to being stuck at 'ready to be compiled' ! Is this something wrong with my code? I am able to run it locally.

Gautham
gautham
Cadet
 
Posts: 4
Joined: Tue Nov 23, 2010 6:07 am
Location: Edinburgh, Scotland

Re: Submission stuck at 'Ready to be compiled'

Postby Janzert » Tue Nov 23, 2010 8:58 am

Your current submission is locking up sbcl for whatever reason. I added timeouts now so it will at least send an error and not break everything.

Janzert
Janzert
Contest Organizer
 
Posts: 271
Joined: Sun Feb 07, 2010 1:59 am

Re: Submission stuck at 'Ready to be compiled'

Postby aerique » Tue Nov 23, 2010 11:28 am

Are you checking locally with the same ancient SBCL (1.0.11) as they're running on the official server, gautham?
aerique
Brigadier-General
 
Posts: 131
Joined: Fri Feb 05, 2010 3:23 pm
Location: Netherlands


Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 2 guests

cron