It is currently Wed Oct 17, 2018 7:20 pm Advanced search

Not a Bug : nothing happens in 200 turns

Code won't compile? Found a bug? Post here!

Not a Bug : nothing happens in 200 turns

Postby Boojum_ » Tue Nov 23, 2010 9:30 pm

Any idea what happened here ? Ended up being a draw, quite logically.

http://ai-contest.com/visualizer.php?game_id=8441123
Last edited by Boojum_ on Wed Nov 24, 2010 7:29 am, edited 1 time in total.
Boojum_
Cadet
 
Posts: 3
Joined: Fri Sep 17, 2010 6:21 pm

Re: Bug : nothing happens in 200 turns

Postby RebelXT » Tue Nov 23, 2010 9:37 pm

most likely both bots decided they can't really attack anything without losing their home planets (even though this is actually not the case for this map), so both bots did issued no orders for 200 turns.

you can check what your bot was thinking during this game by extracting game state from the visualizer and replaying any turn locally:

viewtopic.php?f=18&t=790&start=0
RebelXT
Colonel
 
Posts: 81
Joined: Fri Sep 10, 2010 2:05 pm

Re: Bug : nothing happens in 200 turns

Postby dimkadimon » Wed Nov 24, 2010 4:47 am

My bot got a draw on this map too. I wonder how many bots are smart enough to capture those distant neutrals?

It would be interesting to see some statistics for this map:

* Percentage of draws
* Number of wins by bots who were first to issue an order.

By the way, is anyone else not enjoying these sparse maps?
dimkadimon
Major-General
 
Posts: 263
Joined: Wed Oct 06, 2010 11:34 pm
Location: Adelaide, Australia

Re: Bug : nothing happens in 200 turns

Postby Janzert » Wed Nov 24, 2010 5:27 am

I can easily give you the percentage of draws, but not much else.

The map in that game is map_r538a_30, out of 1941 total games on it 62 (3.2%) have been draws.

Janzert
Janzert
Contest Organizer
 
Posts: 271
Joined: Sun Feb 07, 2010 1:59 am

Re: Bug : nothing happens in 200 turns

Postby Boojum_ » Wed Nov 24, 2010 7:29 am

I may have been a bit hasty in posting... At first I was sure I couldn't spend a first turn without sending anything, then i remembered what I uploaded a few days ago. Sorry :oops:

Thanks anyway. I'll remove the "bug" in the topic.
Boojum_
Cadet
 
Posts: 3
Joined: Fri Sep 17, 2010 6:21 pm


Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 2 guests

cron