[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/functions.php on line 4586: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3765)
[phpBB Debug] PHP Warning: in file /includes/functions.php on line 4588: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3765)
[phpBB Debug] PHP Warning: in file /includes/functions.php on line 4589: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3765)
[phpBB Debug] PHP Warning: in file /includes/functions.php on line 4590: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3765)
AI Challenge Forums • View topic - test_bot.sh doesn't work

It is currently Thu Jan 18, 2018 9:52 am Advanced search

test_bot.sh doesn't work

Topics about starter packages, visualizer or any other third party tools.
Please submit new language requests in the Language Request Forum.

test_bot.sh doesn't work

Postby neiloo » Tue Nov 08, 2011 4:06 am

My test_bot.sh script for testing the bot doesn't work. It says

Traceback (most recent call last):
File "/Users/neil/Dropbox/Ants/tools/engine.py", line 93, in run_game
sandbox.start(bot_cmd)
File "/Users/neil/Dropbox/Ants/tools/sandbox.py", line 383, in start
cwd=working_directory)
File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/subprocess.py", line 679, in __init__
errread, errwrite)
File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/subprocess.py", line 1115, in _execute_child
executable = args[0]
IndexError: list index out of range
waiting 0.25 seconds for bots to process end turn

any suggestion what to do?
neiloo
Cadet
 
Posts: 3
Joined: Tue Nov 08, 2011 4:02 am

Re: test_bot.sh doesn't work

Postby tmc » Wed Nov 09, 2011 10:24 am

tmc
Brigadier-General
 
Posts: 101
Joined: Fri Oct 28, 2011 8:42 am

Re: test_bot.sh doesn't work

Postby slug » Thu Nov 10, 2011 8:45 am

slug
Cadet
 
Posts: 6
Joined: Thu Nov 10, 2011 8:36 am

Re: test_bot.sh doesn't work

Postby crispy » Thu Nov 10, 2011 12:21 pm

crispy
Lieutenant
 
Posts: 10
Joined: Sat Nov 05, 2011 3:07 am

Re: test_bot.sh doesn't work

Postby slug » Thu Nov 10, 2011 1:30 pm

Last edited by slug on Fri Nov 11, 2011 5:37 am, edited 1 time in total.
slug
Cadet
 
Posts: 6
Joined: Thu Nov 10, 2011 8:36 am

Re: test_bot.sh doesn't work

Postby neiloo » Thu Nov 10, 2011 9:29 pm

Hmm.. I tried it like this
./test_bot.sh "MyBot" and it doesn't work..

It says

Traceback (most recent call last):
File "/home/christa3/Dropbox/Ants/tools/engine.py", line 93, in run_game
sandbox.start(bot_cmd)
File "/home/christa3/Dropbox/Ants/tools/sandbox.py", line 385, in start
raise SandboxError('Failed to start {0}'.format(shell_command))
SandboxError: Failed to start ['MyBot']
waiting 0.25 seconds for bots to process end turn

Im using c++ btw.. what should i pass in as the argument?

thanks
neiloo
Cadet
 
Posts: 3
Joined: Tue Nov 08, 2011 4:02 am

Re: test_bot.sh doesn't work

Postby slug » Fri Nov 11, 2011 5:10 am

Try entering the entire path including the extension ("MyBot.c" I'd guess if it's a c/c++ file?).
slug
Cadet
 
Posts: 6
Joined: Thu Nov 10, 2011 8:36 am

Re: test_bot.sh doesn't work

Postby tmc » Fri Nov 11, 2011 1:41 pm

The problem is probably that . is not in your PATH. Run "./testbot.sh ./MyBot" instead.
tmc
Brigadier-General
 
Posts: 101
Joined: Fri Oct 28, 2011 8:42 am

Re: test_bot.sh doesn't work

Postby neiloo » Fri Nov 11, 2011 9:05 pm

Okay that works now.. Thanks a lot for the help :)
neiloo
Cadet
 
Posts: 3
Joined: Tue Nov 08, 2011 4:02 am


Return to Starter Packages & Tools

Who is online

Users browsing this forum: Google [Bot] and 1 guest