[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/functions.php on line 4586: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3765)
[phpBB Debug] PHP Warning: in file /includes/functions.php on line 4588: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3765)
[phpBB Debug] PHP Warning: in file /includes/functions.php on line 4589: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3765)
[phpBB Debug] PHP Warning: in file /includes/functions.php on line 4590: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3765)
AI Challenge Forums • View topic - c++ code runs perfectly home and crashes at server

It is currently Tue Jan 16, 2018 5:04 pm Advanced search

c++ code runs perfectly home and crashes at server

Topics about starter packages, visualizer or any other third party tools.
Please submit new language requests in the Language Request Forum.

c++ code runs perfectly home and crashes at server

Postby xale89 » Sat Dec 03, 2011 6:47 pm

Hi

I've been writing a bot for a while now and have successfully uploaded bots before. But now it the server keeps telling me that the tests fails. The bot runs perfect at my computer and i have tested it in many games on diffrent maps and with diffrent opponents. But the server keeps crashing on my game. Anyone know why? or atleast the exact gamesetup that is the server is running to test the bot? So i can try and reproduce at home?

Thankful for any help!
xale89
(Same nick in the competion)
xale89
Cadet
 
Posts: 4
Joined: Sat Dec 03, 2011 6:42 pm

Re: c++ code runs perfectly home and crashes at server

Postby amstan » Sat Dec 03, 2011 10:02 pm

If you want to install something similar i suggest: Ubuntu 11.04, amd64, using gcc.
Alexandru M. Stan
Contest Organizer
User avatar
amstan
Contest Organizer
 
Posts: 691
Joined: Sun Jan 31, 2010 4:02 am
Location: Stoney Creek, Ontario

Re: c++ code runs perfectly home and crashes at server

Postby xale89 » Mon Dec 05, 2011 12:02 am

Thanks for the info. I've been installing Ubuntu and trying my code.
On the Ubuntu machine I got

"raise SandboxError('Failed to start {0}'. formar(shell_command))
SandboxError: Failed to start ['MyBot']"

Nothing more. It works for other bots (only HunterBots). I tried the bot with just some input data.
MyBot < sample_input.txt
Which generate exactly what i should:
go
0 54 67
go
without any crashes. So i can't say i got any clearification from the ubuntu machine except that its crashing. It looks like the sandbox.py wont even try my program beacause it dont produce any debug text even if it is first in the code.
I just dont get it.
Anyone care to help?
xale89
Cadet
 
Posts: 4
Joined: Sat Dec 03, 2011 6:42 pm

Re: c++ code runs perfectly home and crashes at server

Postby amstan » Mon Dec 05, 2011 5:04 am

Try "./MyBot" if your bot is in the same folder.
Alexandru M. Stan
Contest Organizer
User avatar
amstan
Contest Organizer
 
Posts: 691
Joined: Sun Jan 31, 2010 4:02 am
Location: Stoney Creek, Ontario

Re: c++ code runs perfectly home and crashes at server

Postby xale89 » Mon Dec 05, 2011 6:54 am

Thanks that help with that problem. I got mybot running now on a testmap with 2 other bots using a vm Ubuntu 10.4 64-bit, g++ 4.4.3 (c++-compiler right?). Got any other idea how to test? How could it come that it cant run on the server?
xale89
Cadet
 
Posts: 4
Joined: Sat Dec 03, 2011 6:42 pm

Re: c++ code runs perfectly home and crashes at server

Postby zyberkiddy » Mon Dec 05, 2011 12:27 pm

You can use test_bot.sh to perform the same tests server does. Use it to correct you errors.. You can also see what errors caused to crash if it was because of orders you issued to ants..
zyberkiddy
Cadet
 
Posts: 5
Joined: Sun Dec 04, 2011 11:38 am

Re: c++ code runs perfectly home and crashes at server

Postby xale89 » Mon Dec 05, 2011 6:13 pm

I've found the problem now. I did never test with the test_bot.sh/cmd code. But the problem is not my fault and should be updated by the staff. The testing map contains islands and according to the it should not contain islands.
Staff please comment on this so that I know if I need to change my bot.
xale89
Cadet
 
Posts: 4
Joined: Sat Dec 03, 2011 6:42 pm


Return to Starter Packages & Tools

Who is online

Users browsing this forum: No registered users and 1 guest

cron