It is currently Wed Jul 18, 2018 1:23 am Advanced search

Ruby Early Exit

Code won't compile? Found a bug? Post here!

Ruby Early Exit

Postby stevenheidel » Thu Feb 11, 2010 11:48 pm

I've already tried a dozen times, but each time I get a suspension and early exit. What could be the problem? I'm writing nothing the the IO, bot has a strict time limit, I've tried everything of which I could think. Any ideas?
stevenheidel
Cadet
 
Posts: 4
Joined: Fri Feb 05, 2010 4:30 am

Re: Ruby Early Exit

Postby amstan » Thu Feb 11, 2010 11:59 pm

Did you test locally with the python tournament engine?
Another problem might be that you get a ruby runtime error, compare the versions used.
Alexandru M. Stan
Contest Organizer
User avatar
amstan
Contest Organizer
 
Posts: 691
Joined: Sun Jan 31, 2010 4:02 am
Location: Stoney Creek, Ontario

Re: Ruby Early Exit

Postby stevenheidel » Fri Feb 12, 2010 4:37 am

It works on the tournament fine, works on all boards, works on Ruby 1.9. Can you let me know what the runtime error is?
stevenheidel
Cadet
 
Posts: 4
Joined: Fri Feb 05, 2010 4:30 am

Re: Ruby Early Exit

Postby drasmuss » Fri Feb 12, 2010 11:22 pm

I'm having a similar issue in Python. Runs fine locally, runs fine on all maps with the python tournament engine, but gets immediately suspended with "Early Exit" every time I submit it. Would it be possible to see the actual error messages we're generating? It would help enormously with debugging.
drasmuss
Cadet
 
Posts: 5
Joined: Wed Feb 10, 2010 1:44 am

Re: Ruby Early Exit

Postby amstan » Fri Feb 12, 2010 11:24 pm

Make sure your submission works with ruby 1.9.0(revision 17482).
Alexandru M. Stan
Contest Organizer
User avatar
amstan
Contest Organizer
 
Posts: 691
Joined: Sun Jan 31, 2010 4:02 am
Location: Stoney Creek, Ontario


Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 1 guest

cron