[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file /includes/functions.php on line 4586: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3765)
[phpBB Debug] PHP Warning: in file /includes/functions.php on line 4588: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3765)
[phpBB Debug] PHP Warning: in file /includes/functions.php on line 4589: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3765)
[phpBB Debug] PHP Warning: in file /includes/functions.php on line 4590: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3765)
AI Challenge Forums • View topic - Occasional first turn crash

It is currently Sat Dec 15, 2018 8:01 am Advanced search

Occasional first turn crash

Code won't compile? Found a bug? Post here!

Occasional first turn crash

Postby StairMaster3000 » Sun Oct 17, 2010 5:08 pm

Hey,
So my bot will occasionally time out/crash/not start according to the server on the first turn. It doesn't happen every game, and it seems to go in streaks. When I actually play I do pretty well, but all these first turn losses are killing me! I've tested my code on the output from the visualizer and it runs fine, it doesn't hang and it takes far less than a second. Here's my account:

http://ai-contest.com/profile_games.php?user_id=11290

If anyone has any clue as to what's going on I would love the input. Thanks!
StairMaster3000
Cadet
 
Posts: 1
Joined: Sun Oct 17, 2010 5:05 pm

Re: Occasional first turn crash

Postby Kyunez » Sun Oct 17, 2010 8:03 pm

Had the same trouble.
It would be great if organisers show somewhere reasons for these lost games.
Kyunez
Lieutenant
 
Posts: 11
Joined: Thu Sep 16, 2010 9:30 pm

Re: Occasional first turn crash

Postby Semyglass » Sun Oct 17, 2010 8:52 pm

The same trouble
Semyglass
Lieutenant
 
Posts: 10
Joined: Mon Sep 13, 2010 9:01 am

Re: Occasional first turn crash

Postby ben135 » Sun Oct 17, 2010 10:33 pm

Same, I've been having these for weeks, and I thought it was only c# :)
It was much worse when there was only one server but it's still happening.
ben135
Captain
 
Posts: 21
Joined: Mon Sep 20, 2010 2:57 am

Re: Occasional first turn crash

Postby TioLuiso » Mon Oct 18, 2010 1:59 pm

Same problem here

I'm losing streaks of games on 1st turn, and I'm quite confident my code doesn't break. And the game doesn't even tell me my code has broken or anything. I simple lose. Samples:

http://www.ai-contest.com/visualizer.ph ... id=5948265
http://www.ai-contest.com/visualizer.ph ... id=5951732
http://www.ai-contest.com/visualizer.ph ... id=5946957
http://www.ai-contest.com/visualizer.ph ... id=5944798
http://www.ai-contest.com/visualizer.ph ... id=5943222
http://www.ai-contest.com/visualizer.ph ... id=5942943

Since I didn't change my code recently, I'm starting to believe this is due to a server error, mono error or something like that.
TioLuiso
Cadet
 
Posts: 1
Joined: Mon Oct 18, 2010 1:53 pm

Re: Occasional first turn crash

Postby unsleepable » Thu Nov 25, 2010 2:35 pm

Hi-

I'm having the exact same issue with my Ruby bot. I don't have any issues locally or with the tcp server, and in the contest server it fails very often in the middle of games.

I believe it's a pure time-out issue… Is it possible that the servers are overloaded? Having more information about the failures would be extremely helpful.

Regards
Last edited by unsleepable on Fri Nov 26, 2010 11:30 am, edited 1 time in total.
unsleepable
Cadet
 
Posts: 6
Joined: Thu Nov 25, 2010 2:32 pm

Re: Occasional first turn crash

Postby Mistmanov » Thu Nov 25, 2010 4:07 pm

Mistmanov
Colonel
 
Posts: 70
Joined: Fri Sep 24, 2010 6:50 pm

Re: Occasional first turn crash

Postby unsleepable » Fri Nov 26, 2010 11:32 am

That makes sense, I think you're right. I've also added timers to exit early to avoid time-outs, and the behavior hasn't changed—the bot still crashed half the times.

I really don't know what else to check, as it works without errors or invalid outputs both locally and in the tcp server.
unsleepable
Cadet
 
Posts: 6
Joined: Thu Nov 25, 2010 2:32 pm

Re: Occasional first turn crash

Postby Cthulhu » Fri Nov 26, 2010 6:28 pm

Me too....
i uploaded my new bot that should finally bring me to the top100 (from 140) but all that thing did was collecting timeouts the whole night wich brought me down to a 2k~ish place
Now i have additional time checks all over the place but its still not working properly. and i cannot reproduce it because locally everything is fine. i am curious if i upload a starter packet bot .... will that time out too? :-(
Cthulhu
Cadet
 
Posts: 4
Joined: Wed Nov 24, 2010 10:42 pm

Re: Occasional first turn crash

Postby unsleepable » Fri Nov 26, 2010 7:22 pm

I have also used the Javascript code that you can find in this url to replay the game locally: http://ai-contest.com/forum/viewtopic.p ... 790&p=7069

And no failures… The BOT runs fine. So I guess these must be time-outs, although somehow I find it hard to believe. My bot does not run so intensive calculation and has the timers inside. I don't know, maybe it's a bug…
unsleepable
Cadet
 
Posts: 6
Joined: Thu Nov 25, 2010 2:32 pm


Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 1 guest

cron